Maintenance

Discussion in 'Server News & Announcements' started by Thyestefles, May 9, 2014.

  1. Thyestefles

    Thyestefles Admin Staff Member

    The server is currently down while I upgrade it with the newest rewrite of our custom plugins, as well as the latest Spigot builds. I had hoped for it to be a really quick process however, when starting the servers back up, each one has to contact the Mojang servers and get the UUIDs of the players.

    I already did all that on my end and couldn't care less about Mojang's so-called "fix" for ban-lists. Unfortunately, I don't see a way around allowing it to continue doing its thing, not sure I want to interfere with it anyway.

    I will have everything back up and running ASAP, after I get a chance to test it all out and make sure commands still function the way they are meant to. I did test everything in a test server but, that doesn't always guarantee that everything will be perfect when put into a production server. I don't think anything will pop up, and if something does, it's probably something I can fix without taking too much time.

    We will now be running 1.7.9 and should be almost ready for Mojang to release the name changing feature. It will be a little while before they do that as they are taking into consideration how many servers and developers have to rewrite code to accommodate the change. We should be good on our end, just waiting for other plugins, such as lockette, to update and for 1.8 to be available through Spigot builds.

    I will post an update here as soon as I get it all situated again.
    Brodudee and Arrowmarksman like this.
  2. HaLo2FrEeEk

    HaLo2FrEeEk Active Member

    I wondered why it was down. Cool beans. I really need to stop using the 1.7.2 client, but I haven't looked to see whether any of the mods I use are compatible with the later builds yet. I guess I should do that...
  3. Arrowmarksman

    Arrowmarksman Member

    I'm sure I speak for most here when I say, thank you for all of your hard work Thy! :)
    ElleLightbulb and Brodudee like this.
  4. Thyestefles

    Thyestefles Admin Staff Member

    It seems that the hub has finished updating and Survival just now finished while typing this. I am going to test things out a bit, and wait for the other servers to finish up, then I will be able to open it all up, unless I need to fix/revert something critical.

    I'd say, maybe 10 minutes at the most.
    Brodudee likes this.
  5. HaLo2FrEeEk

    HaLo2FrEeEk Active Member

    Turns out Optifine is officially updated to 1.7.4 and there's a preview for 1.7.9, but Rei's is still, afaik, at 1.7.2, so I'll stick with that until it's updated.
  6. Thyestefles

    Thyestefles Admin Staff Member

    And we're back.

    I had to change a decent amount of code, all relating to player commands and bans, so we may encounter bugs. I don't believe there are any but, if you find something not working like it should, let me know.

    The main thing I could not test by myself was the VIP /protect, so make sure you grab a trusted player and test it out before trusting it atm. Let me know if it is not working, otherwise I will assume it's good.
  7. Secret_Ice

    Secret_Ice New Member

    There is actually a small party of players hanging about the lobby asking the Survival server being down. I've been telling them it's down because of plugin, and server updates. I hope that's okay with ya' Thy.
  8. rwsender

    rwsender Well-Known Member

    its crashed, not down for updates.
    underagedazn and Solidus like this.
  9. antony_cathles

    antony_cathles Moderator Staff Member

    so are we running 1.7.9? As I still can use 1.7.4 so I expect there is another upgrade (or they are compatible)
  10. rwsender

    rwsender Well-Known Member

    its compatiable, im using .2 and it works

Share This Page